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APPENDIX A: TECHNIQUES FOR MODIFYING THE VIEW OF THE 
MODEL WORKSPACE 

Introduction 

During the course of building and analyzing models, you will often want to focus 
on specific areas of the workspace and/or change the manner in which objects 
appear.  Here we will describe the most often used commands for modifying the 
view (or window) displayed on your computer monitor. 

Changing your view will usually be accomplished by employing one or more of 
the following fundamental procedures: 

• Zooming in or out to change the apparent size of objects in your model. 
 

• Panning to move specific parts of your model into the center of your 
viewing area. 
 

• Rotating the orientation from which you view objects. 
 

• Windowing (a combination of Zooming and Panning) to a specific view. 
 

• Hiding some parts of the model when they obstruct your view of objects 
you wish to focus on. 
 

• Shading (also called rendering) objects to make them appear solid. 
 

The program commands for accomplishing each of the above procedures are 
contained in the View menu.  In addition, there are several shortcuts that can be 
activated using your computer’s keyboard and mouse, or speed buttons on 
program tool bars.   

Use of the shortcut methods can greatly increase the speed and efficiency with 
which you use the program, so we will begin with descriptions of keyboard and 
mouse shortcuts. 
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Keyboard Shortcuts 

In the descriptions that follow, standard computer keyboard keys will be shown 
enclosed in angle brackets (<>) to set them apart from the rest of the text.  (For 
example <Home>, <Enter>, <F1>, <Ctrl>.)   

In particular, note that the cursor control arrow keys are also shown according to 
this convention. (For example <Left Arrow>, <Down Arrow>).  This is important 
since you will use the cursor control arrow keys for most procedures. 

Combinations of keystrokes are shown with a plus sign (+) between the keys. 
(For example <Alt>+<Print Screen> means to hold down the <Alt> key and then 
press the <Print Screen> key.) 

 

Arrow Key Shortcuts 

The four arrow keys on your computer keyboard can be used to zoom, pan and 
rotate your model view. 

Zoom <Alt>+<Up Arrow> magnifies your view (zooms in on the 
center of your current view).  

<Alt>+<Down Arrow> zooms out. 

Pan Use <Shift>+ the arrow key for the direction you wish to shift 
the screen view. 

Rotate The <Left Arrow> and <Right Arrow> keys rotate your 
viewpoint to the left or right. 

The <Up Arrow> and <Down Arrow> keys rotate your 
viewpoint up or down. 

The zoom and pan commands are pretty much self-explanatory, but there are 
some fine points about the rotate command that you should understand.  We will 
explain these in the next section. 
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Using the Rotate View Command 

The effects of the Rotate View command will vary 
according to the settings in the View Setup dialog box, 
which is shown at right.  In particular, note the settings 
for the Up Axis (shown outlined in red), the Rotation 
Step (outlined in blue) and the Look At Point (the 
group of three X,Y,Z fields outlined in yellow).   

Imagine that your model space is enclosed within a 
globe.  The globe is free to rotate about the Up Axis, 
and center of the globe is the Look At Point. The 
Rotate View command allows you to spin the globe 
about its axis (in this example the Z Axis), or tilt it to 
change the angle from which you view its center (in 
this example 0,0,0).  Each time the Rotate View 
command is activated, the view will change by a 
specified discrete step (in this example 10 degrees). 

When you first set up a new model, the program defaults are for the positive Z 
Axis to be the Up Axis, and a Rotation Step of 10 degrees.  The Look At Point 
will be automatically set to the center of your model space as determined by your 
Minimum and Maximum Limits settings.  Under certain circumstances, you 
may need to change these settings from their defaults.  This will become clearer 
as you study the following examples. 

Consider the structure shown at right.  
The red arrow lies on, and points in, 
the direction of the positive Z Axis; the 
blue arrow lies on, and points in, the 
direction of the negative Z Axis.  The 
multi-section torus lies in the XY plane. 

 

Note that in the bottom 
left-hand corner of the 
picture there is a small 
set of XYZ axes to show 
the view orientation. 
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If we now press the <Left Arrow> key 
9 times, our viewpoint will rotate to the 
left by 90 degrees.  Note that our 
model appears to have rotated to the 
right. 
 

 

 
If we now press the <Down Arrow> 
key 9 times, our viewpoint will rotate 
downward by 90 degrees.  Note that 
our model appears to have rotated 
upward. 
 

 

 

Note that in the previous examples the red and blue arrows were aligned 
vertically.  In fact, because the Z Axis is set as the Up Axis, you cannot tilt the 
arrows to a diagonal or horizontal orientation.  To overcome this restriction, we 
need to change the setting of the Up Axis. 

At right, we have changed the setting so that 
the Y Axis is now the new Up Axis. We can 
now tilt the arrows away from a strictly 
vertical alignment. (We could also have 
accomplished this by setting the X Axis as 
the Up Axis.) 

 

 

The orientation indicator 
also rotates 10 degrees 
at each step to reflect the 
changing view direction. 

Once again, the 
orientation indicator 
changes to reflect the 
new view direction. 

With this new setting, the 
orientation indicator displays 
the Y Axis as vertical. 
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You can change the current Up Axis by opening the View Setup dialog box, but 
usually it is more convenient to change the setting on the Utilities toolbar as 
shown below. 

 

Another problem can occur when you have zoomed in on a small section of your 
model space that is located far from the default Look At Point.   

An example of this situation is shown at 
right, where we have zoomed in on the tip 
of the red arrow 

If we now attempt to rotate our view to look 
down on the tip from above, it will pass 
down out of the viewing area of our screen 
after a few rotation steps.  We will then 
have to pan down until the tip is again 
visible.  

A better solution is to move the coordinates of the 
Look At Point closer to the arrow tip.  You can 
do this by changing the setting in the View Setup 
dialog box, but again the Utilities tool bar has a 
speed button for this as shown at right. 

 

Clicking the speed button will cause the Command Line to show the prompt 
Select or enter new look at point <x,y,z> as shown below. 

 



 Appendix A 
   
 

 

6 

For some cases you will know the 
appropriate coordinates to enter, but 
usually it is easier just to select an existing 
geometry point with your mouse as shown 
at right (we changed the display to wire 
frame to make the points easier to see). 

Note that the mouse pointer can only be 
used to select existing geometry points in 
3D mode.   Clicking on blank sections of 
the model space will not produce a 
selection.  

 

<Home> and <Page Up> 

If you have zoomed in on a small detail of a model, you can quickly zoom out to 
view the full workspace by pressing the <Home> key on your computer 
keyboard. 

If you have used several different view windows since starting the program, you 
can backtrack through them one at a time by pressing the <Page Up> key.  You 
can back up through a maximum of 32 previous view windows. 

 

Keyboard Template 

As a reference and reminder 
for the functions of the 
keyboard shortcuts, you can 
open a template window. 

Select Help>Keyboard as 
shown at right. 
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Mouse Shortcuts 

Mouse shortcuts also allow you to zoom, pan and rotate your model view.  The 
mouse shortcuts are more flexible than the arrow key shortcuts since they 
provide continuous (or real-time) view modifications (as opposed to the discrete 
steps that occur each time you press an arrow key). 

Zoom With your mouse pointer over the workspace, 
press <Alt>+Left Mouse Button.  The pointer will 
change to a magnifying glass. 

When this occurs, move your mouse up (or down) to zoom in 
(or out). 

(Also, if you have a scrolling mouse you can rotate the 
center wheel to zoom by discrete steps in the same manner 
as you would by using the cursor arrow keys.) 

 

Pan With your mouse pointer over the workspace, press 
<Shift>+Left Mouse Button.  The pointer will 
change to an omni directional indicator.  

When this occurs, move your mouse in the direction you 
wish to pan. 

(You can of course also pan by using your mouse to drag the 
horizontal or vertical scroll bars at the bottom and right sides 
of the workspace.) 

 

Rotate With your mouse pointer over the workspace, 
press <Alt>+Right Mouse Button.  The pointer 
will change to rotational arrows. 

When this occurs, move your mouse in the direction you 
wish to rotate.  
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Using Window Commands 

The four Window commands combine zooming and panning in one operation.  
They are called window commands because you define your next view window 
by using the mouse to draw a “rubber” box outline to select the desired part of 
your workspace. 

The Window commands can be accessed through the View menu, or using the 
speed buttons on the View tool bar shown below. 

The four Window commands fall into one of two categories: they are either 
Window All or Window Current.  The distinction between the two types is 
explained as follows: 

• Window Current commands allow you to select a subsection of the 
currently displayed view to be you next view window.  They can only be 
used to zoom in (not out) for your next view. 
 

• Window All commands allow you to select any portion of your entire 
model space to be your next view window.  If you have zoomed in on a 
small region, activating a Window All command will cause the display to 
immediately zoom out to the full extent of the view limits.  You then draw 
your selection box for you next view. (Essentially, the Window All 
commands save you the step of using the View All command to display 
your full model before defining your new window.) 
 

Window commands can also be Dynamic.  Dynamic Window commands allow 
you to first draw the selection box to the size you want, and then position the box 
to enclose the portion of your model space that will be the next view window. 

The procedure for using Window commands will be illustrated by an example in 
the next section. 
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Dynamic Window All Example 

We will use our previous model to demonstrate the Dynamic Window All 
command.  Specifically, we will begin with a view that is zoomed in on the top 
arrow (shown below at left) and end zoomed in on the bottom arrow (below right).

      

NOTE: The terms Left-click and Right-click refer to pressing the left and right 
buttons of your mouse when your mouse pointer is located in the workspace of 
your program window.  

1) On the View tool bar, click the 
[Dynamic Window All] speed 
button bar to start the 
command. 

2) Your view will zoom out to 
display the entire workspace 
and the Command Line will 
show the prompt Locate lower 
left corner (of the selection 
box). 

3) Left-click anywhere in the 
workspace to begin the box. 

4) The Command Line will show 
the prompt Locate lower right 
corner. 
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5) Move your mouse pointer horizontally.  Note that the 
outline of a box is drawn as you move the mouse, and 
that the box maintains a fixed aspect ratio (which is the 
same aspect ratio as your program window).  

6) When the box is big enough to contain the arrow tip, Left-click to fix its 
size. 

7) The selection box will snap to the cross hairs of the 
mouse pointer, and the Command Line will show the 
prompt Locate Window Center.  

 
8) Move the selection box onto the bottom arrow tip and 

Left-click to complete the command. 

 

 

 
We could have also used the Window All command to shift 
our view.  The main difference is that the Window All 
command would have executed as soon as the lower right 
corner of the box had been located. 

When using Window All you must take 
extra care in locating the corners since you 
do not get an opportunity to center the box. 

  
 
 

 
The first few times you use the Window commands, you 
should pay special attention to the Message Area prompts to 
ensure you follow the proper sequence of operations. 
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Stretch Mode 

In the previous example, we could vary the size and location of the selection box, 
but we could not change its aspect ratio.  This was fixed to the same aspect ratio 
as the program window in order to give an undistorted view of objects in the 
model space.  However, there are occasions when physical structures to be 
modeled have extreme aspect ratios, and in these cases distorting the view by 
compressing or stretching dimensions can be helpful.   

To accommodate these situations, the program can be set to display the model 
space in Stretch Mode View.   This can be set in the View menu, or by the 
speed button on the View tool bar as shown below. 

 

When the program is in Stretch Mode View, selection boxes for the Window 
commands are free of aspect ratio restrictions.  In the view shown below at left, 
we first enabled Stretch Mode View and then activated the Window Current 
command.  A narrow selection box has been drawn that is just large enough to 
enclose the red and blue arrows.  As a result, the arrows appear wider when the 
new view is displayed (shown below at right). 
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Using Visibility Commands 

Quite often, you will want to focus on parts of a model that are either partially or 
completely surrounded by other objects.  In these situations you will need to 
temporarily hide the surrounding objects by using Visibility commands. 

The Visibility commands can be accessed through the View menu, or using the 
speed buttons on the View tool bar shown below. 

 

The All Visibility On, All Visibility Off and Visibility Toggle commands 
execute in one step since they operate on all objects in your model space and as 
such do not require selection of specific model parts.   However, you should keep 
in mind that the results of the Visibility Toggle command will vary according to 
the settings for the Geometry Selection Type in the Utilities tool bar. 

The Visibility On and Visibility Off commands require that you first build a 
selection set of objects that will be subject to the commands.  In the case of 
Visibility On, the visibility of objects in your model space will first toggle (all 
currently visible objects will become hidden and all currently invisible objects will 
reappear) to allow you to build your selection set. 

After a Visibility command has been 
executed, the Message Area will display a 
summary of the number of segments that are 
currently invisible as shown at right. 
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If you need to make most of your model invisible, first execute 
the All Visibility Off command, then use the Visibility On 
command to turn on the objects you need to see. 
Also, you may find it helpful to use the [Define Group] speed 
button on the Geometry Operation tool bar to assign objects 
of your model to different Groups.  This will enable you to hide 
or display large numbers of related items with a single 
selection operation. 

 

 

 

Using the Standard View Tool Bar 

We will complete our discussion of the techniques for modifying your view by 
describing the functions of the Standard View tool bar. 

 

Options for Displaying Objects 

Objects in your model space are displayed as Wireframe structures by default, 
but they can also be shown in Solid, Hidden line, or Translucent view by 
clicking the appropriate speed button on the Standard View tool bar shown 
below. 

 



 Appendix A 
   
 

 

14 

The following are general guidelines for using each display mode. 

• Solid view produces a very real life visualization of your model.  It is 
helpful in displaying boundary condition and material assignments.  It also 
provides the best indication when you are in the process of selecting 
surfaces or volumes. 

• Wireframe view is useful for selecting individual geometry points and 
segments.  It can however, lead to confusion when you are rotating your 
model view. 

• Hidden line and Translucent view provide good 3D visualization, and 
are especially useful for viewing element meshes on surfaces. 

 

 
The View>Shading submenu contains four 
options that allow you to control the quality of 
rendered views. 

 
Use the Coarse setting when saving models (the database 
will then load faster the next time you open it), and to 
produce faster rotation of complex models. 

 

 

 

Options for Rapid View Alignment 

The Standard View tool bar contains speed buttons that permit you to rapidly 
change your model orientation (without have to use the Rotate View command) 
as shown below. 
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